JCU Network Connectivity Issues
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Apr 05, 2021 - 15:09 EDT
Monitoring
Service Restored: 4/5/21 2:15 pm

JCU ITS has confirmed that all network connectivity issues have been resolved. We are working with the network provider to determine the root cause of the problem.

If you have questions or continue to experience problems, please contact the JCU Service Desk at 216-397-3005 or servicedesk@jcu.edu.

Information Technology Services
216-397-3005
jcu.edu/its
Posted Apr 05, 2021 - 14:31 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 05, 2021 - 14:07 EDT
Identified
Some users are experiencing network issues on campus. Information Technology Services is aware of the problem and will post updates on our Status Page (https://status.jcu.edu/) as they become available.

We sincerely apologize for this situation and appreciate your patience. Please call the JCU Service Desk at 216-397-3005 for any questions or concerns you have.

Information Technology Services
216-397-3005
jcu.edu/its
Posted Apr 05, 2021 - 14:06 EDT
This incident affected: Network (Wired/Wireless) (Administration Building, Rodman Hall, Boler College of Business, O'Malley Center, Grasselli Library & Breen Learning Center, Dolan Science Center).