Campus Wide Network Outage
Incident Report for John Carroll University
Resolved
A fix has been applied to the network access system which seems to have corrected a problem that restricted some devices from connecting to the wireless network. It is important for you to contact the ITS Service Desk if you are still not able to connect as we want to ensure that everything is working correctly.

We appreciate your patience as we worked through this issue. Outage updates are also available on the ITS Status Page (https://status.jcu.edu).

--
Information Technology Services
Posted Aug 30, 2022 - 17:16 EDT
Update
We are continuing to monitor for any further issues.
Posted Aug 29, 2022 - 10:48 EDT
Monitoring
A fix has been implemented and we are monitoring the results over the weekend.

Please give us a call if you are having any issues connecting to the JCU network.

Information Technology Services
216-397-3005
Posted Aug 27, 2022 - 12:27 EDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 26, 2022 - 09:59 EDT
Identified
We have restored the network and phones for most buildings. It seems like some users are still having issues connecting to the network.

Please call the JCU Service Desk at 216-397-3005 if you have any questions or need assistance.
Posted Aug 26, 2022 - 09:58 EDT
Investigating
We are experiencing a disruption in the campus network affecting both computer access and phones. ITS engineers are working with the vendor's Critical Response Team to resolve this issue as quickly as possible. Please know that this has the full and complete attention of the ITS team and the vendor's highest-level technical staff and executives.

We sincerely apologize for this situation and appreciate your patience. Please call the JCU Service Desk at 216-397-3005 for any questions or concerns you have. Your call will be answered by our after-hours emergency support team.
Posted Aug 26, 2022 - 08:37 EDT
This incident affected: Campus Notification and Network (Wired/Wireless) (Administration Building, Rodman Hall, Boler College of Business, O'Malley Center, Grasselli Library & Breen Learning Center, Dolan Science Center, Residence Halls, Everstream Internet Circuit, D.J. Lombardo Student Center, Schell House).